summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-18 00:40:26 -0400
committerLeo Famulari <leo@famulari.name>2016-03-18 14:27:16 -0400
commit603d665bc3767f73d4b78f52fb20cf76e21689fc (patch)
tree47e0d923f999222ac90fba4aba3a25e84b9a5058 /gnu/packages/python.scm
parentacd7351ff641fdd258c0d2af4a416386015940a4 (diff)
downloadpatches-603d665bc3767f73d4b78f52fb20cf76e21689fc.tar
patches-603d665bc3767f73d4b78f52fb20cf76e21689fc.tar.gz
gnu: Add python-cookies.
* gnu/packages/python.scm (python-cookies, python2-cookies): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d7828fb233..9144a37de4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8284,3 +8284,33 @@ presume or force a developer to use a particular tool or library.")
(package (inherit (package-with-python2
(strip-python2-variant python-flask)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-cookies
+ (package
+ (name "python-cookies")
+ (version "2.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cookies" version))
+ (sha256
+ (base32
+ "13pfndz8vbk4p2a44cfbjsypjarkrall71pgc97glk5fiiw9idnn"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; test are broken: https://gitlab.com/sashahart/cookies/issues/3
+ #:tests? #f))
+ (native-inputs
+ `(("python-pytest" ,python2-pytest)))
+ (synopsis "HTTP cookie parser and renderer")
+ (description "A RFC 6265-compliant HTTP cookie parser and renderer in
+Python.")
+ (home-page "https://gitlab.com/sashahart/cookies")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-cookies))))))
+
+(define-public python2-cookies
+ (let ((cookies (package-with-python2
+ (strip-python2-variant python-cookies))))
+ (package (inherit cookies)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs cookies))))))