summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-17 11:31:59 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-17 13:49:18 +0100
commitdb62afa55ad443cc50bcafe64eb3ba239eae9c11 (patch)
tree4ab236d562bb551ec9afea505b3126f2bdb086fb /gnu/packages/python.scm
parentf767bccabfb2870b8e9970bb8cbcbad81d7943ca (diff)
downloadpatches-db62afa55ad443cc50bcafe64eb3ba239eae9c11.tar
patches-db62afa55ad443cc50bcafe64eb3ba239eae9c11.tar.gz
gnu: Add python2-xlib.
* gnu/packages/python.scm (python2-xlib): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d014553e78..2fcdbcc211 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3348,3 +3348,28 @@ Python style, together with a fast and comfortable execution environment.")
(define-public python2-testlib
(package-with-python2 python-testlib))
+
+(define-public python2-xlib
+ (package
+ (name "python2-xlib")
+ (version "0.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/python-xlib/"
+ "python-xlib-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sv0447j0rx8cgs3jhjl695p5pv13ihglcjlrrz1kq05lsvb0wa7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ;Python 2 only
+ #:tests? #f)) ;no tests
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://python-xlib.sourceforge.net/")
+ (synopsis "Python X11 client library")
+ (description
+ "The Python X Library is intended to be a fully functional X client
+library for Python programs. It is useful to implement low-level X clients.
+It is written entirely in Python.")
+ (license gpl2+)))