summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-12 15:46:40 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-26 15:29:01 +0200
commit0dde623211096642013bf05879982214dfb08b25 (patch)
tree6161fbc29ea6bb01160e89d8b843a36eef1ab08c /gnu/packages/python.scm
parent74cc67372ec3771b157c015da4ba7ed5d921799f (diff)
downloadpatches-0dde623211096642013bf05879982214dfb08b25.tar
patches-0dde623211096642013bf05879982214dfb08b25.tar.gz
gnu: Add python2-pysnptools.
* gnu/packages/python.scm (python2-pysnptools): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4f7b1aae08..7ddfcc6ffe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2598,6 +2598,39 @@ toolkits.")
(package-propagated-inputs
matplotlib))))))))
+(define-public python2-pysnptools
+ (package
+ (name "python2-pysnptools")
+ (version "0.2.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/pysnptools"
+ "/pysnptools-" version ".zip"))
+ (sha256
+ (base32
+ "1rzf5qvwfvd2pp84b14pb2gdvxdk5avnj7rb41ac8gndpkr9g6ib"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2)) ; only Python 2.7 is supported
+ (propagated-inputs
+ `(("python2-numpy" ,python2-numpy)
+ ("python2-scipy" ,python2-scipy)
+ ("python2-pandas" ,python2-pandas)
+ ("python2-cython" ,python2-cython)))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python2-setuptools" ,python2-setuptools)))
+ (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/")
+ (synopsis "Library for reading and manipulating genetic data")
+ (description
+ "PySnpTools is a library for reading and manipulating genetic data. It
+can, for example, efficiently read whole PLINK *.bed/bim/fam files or parts of
+those files. It can also efficiently manipulate ranges of integers using set
+operators such as union, intersection, and difference.")
+ (license asl2.0)))
+
(define-public python-scipy
(package
(name "python-scipy")