summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-07 21:27:08 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:06 +0100
commit328bb95d3507682f5e06fb2880c632252f59ee57 (patch)
tree297fa2f12c1a3b4bedac0b50a61049bb1a749ee9 /gnu/packages/python.scm
parent482d95918e2a9de05ee224d979c15759e54febf0 (diff)
downloadpatches-328bb95d3507682f5e06fb2880c632252f59ee57.tar
patches-328bb95d3507682f5e06fb2880c632252f59ee57.tar.gz
gnu: Fix python inputs, part 6: some inputs become native-inputs.
This patch handles the inputs which are native-inputs almost always like nose, sphinx, and pytest. * gnu/packages/python.scm (python-jsonschema, python-numpydoc, python-mccabe, python-mistune, python-ptyprocess, python-webob, python-apipkg, python-flake8-2.2.4)[inputs] change to [native-inputs]. (python-flake8, tox) Likewise, add a comment. (python-scikit-learn, python-numpy)[native-inputs] New element, move python-nose here. (python2-kombu)[inputs] change to [native-inputs], use python-kombu's package-native-inputs.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0ac7db9265..3442488d29 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2940,8 +2940,9 @@ and is very extensible.")
(system* "nosetests" "-v" "sklearn")))
(alist-delete 'check %standard-phases)))))
(inputs
- `(("openblas" ,openblas)
- ("python-nose" ,python-nose)))
+ `(("openblas" ,openblas)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)))
@@ -3126,9 +3127,10 @@ between language specification and implementation aspects.")
(base32
"1bjjhvncraka5s6i4lg644jrxij6bvycxy7an20gcz3a0m11iygp"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
(inputs
- `(("python-nose" ,python-nose)
- ("openblas" ,openblas)
+ `(("openblas" ,openblas)
("lapack" ,lapack)))
(native-inputs
`(("gfortran" ,gfortran)))
@@ -3345,7 +3347,7 @@ that client code uses to construct the grammar directly in Python code.")
(substitute* "numpydoc/tests/test_plot_directive.py"
(("3") "2"))))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-docutils" ,python-docutils)
("python-sphinx" ,python-sphinx)
("python-nose" ,python-nose)))
@@ -5489,7 +5491,7 @@ PEP 8.")
(base32
"0yr08a36h8lqlif10l4xcikbbig7q8f41gqywir7rrvnv3mi4aws"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/flintwork/mccabe")
@@ -5570,8 +5572,8 @@ complexity of Python source code.")
`(("python-pep8" ,python-pep8)
("python-pyflakes" ,python-pyflakes)
("python-mccabe" ,python-mccabe)))
- (inputs
- `(("python-mock" ,python-mock)
+ (native-inputs
+ `(("python-mock" ,python-mock) ; TODO: only required for < 3.3
("python-nose" ,python-nose)))
(home-page "https://gitlab.com/pycqa/flake8")
(synopsis
@@ -5591,7 +5593,7 @@ complexity of Python source code.")
`(("python-pep8" ,python-pep8-1.5.7)
("python-pyflakes" ,python-pyflakes-0.8.1)
("python-mccabe" ,python-mccabe-0.2.1)))
- (inputs
+ (native-inputs
`(("python-mock" ,python-mock)
("python-nose" ,python-nose)))
(version "2.2.4")
@@ -5621,7 +5623,7 @@ complexity of Python source code.")
(base32
"17zqjp9m4d1w3jf2rbbq5xshcw24q1vlcv24gkgfqqyyymajxahx"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-nose" ,python-nose)
("python-cython" ,python-cython)))
(home-page "https://github.com/lepture/mistune")
@@ -5680,7 +5682,7 @@ markdown_py is also provided to convert Markdown files to HTML.")
(base32
"0nggns5kikn32yyda2zrj1xdmh49pi3v0drggcdwljbv36r8zdyw"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-nose" ,python-nose)))
(arguments
`(#:phases
@@ -5994,7 +5996,7 @@ fractional seconds) of a clock which never goes backwards.")
(base32
"02bhhzijfhv8hmi1i54d4b0v43liwhnywhflvxsv4x3zax9s3afq"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-nose" ,python-nose)))
(home-page "http://webob.org/")
(synopsis "WSGI request and response object")
@@ -7640,7 +7642,7 @@ applications.")
(base32
"1iks5701qnp3dlr3q1d9qm68y2plp2m029irhpz92a44psfkjf1f"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-pytest" ,python-pytest)))
(synopsis "Namespace control and lazy-import mechanism")
(description "With apipkg you can control the exported namespace of a Python
@@ -8184,8 +8186,8 @@ Pytest but stripped of Pytest specific details.")
`(("python-pluggy" ,python-pluggy) ; >=0.3.0,<0.4.0
("python-py" ,python-py)
("python-virtualenv" ,python-virtualenv)))
- (inputs
- `(("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest))) ; >= 2.3.5
(home-page "http://tox.testrun.org/")
(synopsis "Virtualenv-based automation of test activities")
(description "Tox is a generic virtualenv management and test command line
@@ -8776,8 +8778,8 @@ RabbitMQ messaging server is the most popular implementation.")
(strip-python2-variant python-kombu))))
(package
(inherit kombu)
- (inputs `(("python2-unittest2" ,python2-unittest2)
- ,@(package-inputs kombu))))))
+ (native-inputs `(("python2-unittest2" ,python2-unittest2)
+ ,@(package-native-inputs kombu))))))
(define-public python-billiard
(package