summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-10 12:14:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:28 +0100
commit521b77729e6383b1de10838395625a4b2aa5ff9e (patch)
tree5d5094264cc71a495cf9a64c01b6448fce2bf249 /gnu/packages/python.scm
parentabcc7a0eb9ddb975689a56d818c6a44605211b43 (diff)
downloadpatches-521b77729e6383b1de10838395625a4b2aa5ff9e.tar
patches-521b77729e6383b1de10838395625a4b2aa5ff9e.tar.gz
gnu: python-scripttest: Correct inputs.
python-pytest is only required for testing, not at run-time. * gnu/packages/python.scm (python-singledispatch, python2-singledispatch): [propagated-inputs] Move python-pytest to [native-inputs].
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 234f85672f..b349e3f552 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1821,7 +1821,7 @@ result back.")
(base32
"0f4w84k8ck82syys7yg9maz93mqzc8p5ymis941x034v44jzq74m"))))
(build-system python-build-system)
- (propagated-inputs
+ (native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "http://pythonpaste.org/scripttest/")
(synopsis "Python library to test command-line scripts")