summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-17 20:49:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-17 20:49:39 +0100
commit26176bee23706669c7402c8bd083ed29187fe8e9 (patch)
tree0e70111b172743b239c123f3b1b905f804d53785 /gnu/packages/python.scm
parent9729f9756c6f4b8376fc619b1330b05b8892c21a (diff)
downloadpatches-26176bee23706669c7402c8bd083ed29187fe8e9.tar
patches-26176bee23706669c7402c8bd083ed29187fe8e9.tar.gz
gnu: python-waitress: Update to 1.1.0.
* gnu/packages/patches/python-waitress-fix-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python.scm (python-waitress): Update to 1.1.0. [source](patches): New field.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6e5e804c34..257489d09b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7550,14 +7550,15 @@ templates into Python modules.")
(define-public python-waitress
(package
(name "python-waitress")
- (version "0.8.10")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "waitress" version))
+ (patches (search-patches "python-waitress-fix-tests.patch"))
(sha256
(base32
- "017n9ra6vvmq9d5sfhdzyzr1mg15x2hj2dhm4pdlw98c1ypw2h3w"))))
+ "1a85gyji0kajc3p0s1pwwfm06w4wfxjkvvl4rnrz3h164kbd6g6k"))))
(build-system python-build-system)
(home-page "https://github.com/Pylons/waitress")
(synopsis "Waitress WSGI server")