summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:01:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commit8fa2bcc7935a27bba9aa03cbee5d1c3b4a014e9b (patch)
tree603cc59ea9f6aed02bbaa5d760e0516f54737b11 /gnu/packages/python-xyz.scm
parent5b77ebe15c81c0ef60ad625a293f99a2e0bc8624 (diff)
downloadpatches-8fa2bcc7935a27bba9aa03cbee5d1c3b4a014e9b.tar
patches-8fa2bcc7935a27bba9aa03cbee5d1c3b4a014e9b.tar.gz
gnu: python-glob2: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-glob2)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37225a9f47..37ce723326 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14175,16 +14175,15 @@ manager compatible with @code{asyncio}.")
(package
(name "python-glob2")
(version "0.6")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/miracle2k/python-glob2/archive/"
- version
- ".tar.gz"))
- (sha256
- (base32
- "0ja168f0dz4kbz4m06dm0rd3acaypk6hjx2km541pw22y9s40mag"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miracle2k/python-glob2.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lm1xz3k3l0k1c5bcp9hlzmi3gp5j8dl1k3xhpiq5mnm0xq6n163"))))
(build-system python-build-system)
(home-page "https://github.com/miracle2k/python-glob2/")
(synopsis "Extended Version of the python buildin glob module")