summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-16 08:31:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:34 +0100
commit0e648e616094b20ffc3b296a27fb01e3085acf38 (patch)
treea64e2918e13eae88bd60fa5d7e16e29dcc517c65 /gnu/packages/python-xyz.scm
parent0ae97f5dd1c6cc2ad8e9f27f62e5a72e0d5fbb4c (diff)
downloadpatches-0e648e616094b20ffc3b296a27fb01e3085acf38.tar
patches-0e648e616094b20ffc3b296a27fb01e3085acf38.tar.gz
gnu: python-mako: Do not use pytest nose compatibility layer.
* gnu/packages/python-xyz.scm (python-mako)[native-inputs]: Replace PYTHON-PYTEST with PYTHON-NOSE. [arguments]: Adjust check phase accordingly. While at it, allow overriding the #:tests? key.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12faca73eb..1de855f617 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8990,13 +8990,16 @@ python-xdo for newer bindings.)")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "nosetests" "-v")
+ (format #t "test suite not run~%"))
+ #t)))))
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
(native-inputs
`(("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)))
+ ("python-nose" ,python-nose)))
(home-page "https://www.makotemplates.org/")
(synopsis "Templating language for Python")
(description "Mako is a templating language for Python that compiles