summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-06 10:07:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-06 10:07:36 +0200
commit378d94e51b00c30b19a39154278d01f1f3c4dbc1 (patch)
tree0c9ed3a1c1b6db778b05ad03fa8edd91cfb737f4 /gnu/packages/python-xyz.scm
parentd350d5e71434704d147b1252d21e46daf6bb9885 (diff)
parent6a5198170ed5f10e1eee2e25fc6a39f3f33a40fd (diff)
downloadpatches-378d94e51b00c30b19a39154278d01f1f3c4dbc1.tar
patches-378d94e51b00c30b19a39154278d01f1f3c4dbc1.tar.gz
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 18 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca3e3b642b..b937eef63a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10942,25 +10942,36 @@ command @command{natsort} that exposes this functionality in the command line.")
(define-public python-glances
(package
(name "python-glances")
- (version "3.0.2")
+ (version "3.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Glances" version))
(sha256
(base32
- "09fxysfp1n16csqvzvawy74qm6a94nvwjf3vcf5gkqp4i6k4vjjy"))))
+ "07j1ggzsqiskyz1i4mrnyr9i95v0dqi0i0hibnv1l188km8shmi8"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Glances phones PyPI for weekly update checks by default.
+ ;; Disable these. The user can re-enable them if desired.
+ (substitute* "glances/outdated.py"
+ (("^(.*)self\\.load_config\\(config\\)\n" line indentation)
+ (string-append indentation
+ "self.args.disable_check_update = True\n"
+ line)))
+ #t))))
(build-system python-build-system)
(propagated-inputs
- `(("python-psutil" ,python-psutil)))
+ `(("python-future" ,python-future)
+ ("python-psutil" ,python-psutil)))
(home-page
"https://github.com/nicolargo/glances")
- (synopsis
- "A cross-platform curses-based monitoring tool")
+ (synopsis "Cross-platform curses-based monitoring tool")
(description
"Glances is a curses-based monitoring tool for a wide variety of platforms.
-Glances uses the PsUtil library to get information from your system. It monitors
-CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
+Glances uses the PsUtil library to get information from your system. It
+monitors CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
(license license:lgpl3+)))
(define-public python2-glances