summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 03:51:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 03:55:45 +0100
commitc91ecf2db4c24159a2db1c153541f55642315892 (patch)
tree8621299087c88f3054b0e54fa7926356bdc69c6d /gnu/packages/python-xyz.scm
parent51a9971ccb631e56d67f2cf71c2d8defae73955c (diff)
downloadpatches-c91ecf2db4c24159a2db1c153541f55642315892.tar
patches-c91ecf2db4c24159a2db1c153541f55642315892.tar.gz
gnu: Add python-annoy.
* gnu/packages/python-xyz.scm (python-annoy): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de546f2618..f392b52235 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15275,3 +15275,26 @@ and dates in \"human readable\" forms. For example, it would display
(description "This is a collection of well-tested, simple modules and
functions that aim to reduce boilerplate when working with data.")
(license license:bsd-2)))
+
+(define-public python-annoy
+ (package
+ (name "python-annoy")
+ (version "1.15.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "annoy" version))
+ (sha256
+ (base32
+ "1rxn6snn0r32r07g45hdjhh8aa1xzx6fjrm8g62d8vzp46z7rzrp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/spotify/annoy/")
+ (synopsis "Approximate nearest neighbors library")
+ (description
+ "Annoy is a C++ library with Python bindings to search for points in
+space that are close to a given query point. It also creates large read-only
+file-based data structures that are @code{mmap}ped into memory so that many
+processes may share the same data.")
+ (license license:asl2.0)))