summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:01:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commit5b77ebe15c81c0ef60ad625a293f99a2e0bc8624 (patch)
treed323c9d2db43c0876804931cdb63a84feb0afa56 /gnu/packages/python-xyz.scm
parent1a04d421951eea118c1a9fe523d49c096b054386 (diff)
downloadpatches-5b77ebe15c81c0ef60ad625a293f99a2e0bc8624.tar
patches-5b77ebe15c81c0ef60ad625a293f99a2e0bc8624.tar.gz
gnu: python-dukpy: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-dukpy)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a000ec26c..37225a9f47 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13102,13 +13102,13 @@ executed more than a given number of times during a given period.")
(version "0.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/kovidgoyal/dukpy/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kovidgoyal/dukpy.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0pj39rfwlzivqm5hkrsza7gssg6ggpxlq5ivc8f3h7x5pfgc6y6c"))))
+ (base32 "13h21nqzasv4zj32xs61brmc106pr2cx243672crcmwxxnjgaxls"))))
(build-system python-build-system)
(home-page "https://github.com/kovidgoyal/dukpy")
(synopsis "Run JavaScript in python")