summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:01:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commit1961d18791d3d929889471ab5cc1676cba0e33a1 (patch)
tree6bec88e13858c01f574a4ac7ec8ce876f98aea45 /gnu/packages/python-xyz.scm
parent3e3ff8ad13a4990369a87b83dec72d5db9646628 (diff)
downloadpatches-1961d18791d3d929889471ab5cc1676cba0e33a1.tar
patches-1961d18791d3d929889471ab5cc1676cba0e33a1.tar.gz
gnu: python-schematics: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-schematics)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f3409707ba..5b3d475e46 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10239,20 +10239,21 @@ discovery, monitoring and configuration.")
(name "python-schematics")
(version "1.1.1")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/schematics/schematics/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "19v1i69bf3bzarfxmbv0v6ivpcn758x3shvbiy9l2hy0lvqwnp6l"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schematics/schematics.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xdqskycznqc7mfp60bhw1zq8wx7yx1dvmbq3brnm1dx3xnqa0zd"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))
(arguments
- `(#:tests? #f)) ; requires a bunch of not very nice packages with fixed
- ; version requirements (eg python-coveralls)
+ ;; The tests require a bunch of not very nice packages with fixed
+ ;; version requirements (e.g. python-coveralls).
+ `(#:tests? #f))
(home-page "https://github.com/schematics/schematics")
(synopsis "Python Data Structures for Humans")
(description "Python Data Structures for Humans.")