summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-16 16:25:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-16 17:27:03 +0100
commitdbcef44a0bdc5472cd49cd02d9d11a9c5ff037c9 (patch)
treed4ceb2ac2ae0f5050535caedb3e6f563401e94e2 /gnu/packages/python-xyz.scm
parentd0a26d0be9b1bdf00cfc20ddac6236e840707d27 (diff)
downloadpatches-dbcef44a0bdc5472cd49cd02d9d11a9c5ff037c9.tar
patches-dbcef44a0bdc5472cd49cd02d9d11a9c5ff037c9.tar.gz
gnu: Add python-iocapture.
* gnu/packages/python-xyz.scm (python-iocapture): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9fac87648a..2ec13b7c15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16786,3 +16787,42 @@ services to what you expect in your tests.")
(define-public python2-ujson
(package-with-python2 python-ujson))
+
+(define-public python-iocapture
+ ;; The latest release is more than a year older than this commit.
+ (let ((commit "fdc021c431d0840303908dfc3ca8769db383595c")
+ (revision "1"))
+ (package
+ (name "python-iocapture")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oinume/iocapture.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mkbhqibxvgwg0p7slr8dfraa3g2s6bsayladhax2jccwj4kcndz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test" "-v" "tests")
+ #t)))))
+ (propagated-inputs
+ `(("python-flexmock" ,python-flexmock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/oinume/iocapture")
+ (synopsis "Python capturing tool for stdout and stderr")
+ (description
+ "This package helps you to capture the standard out (stdout) and the
+standard error channel (stderr) in your program.")
+ (license license:expat))))