summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-06 09:15:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-06 09:15:33 +0200
commit957c683354a9c35c630dac16a1015b54d1909b81 (patch)
tree4b86e4a3feea2f8a597482f57ceb6dba91930c9a /gnu/packages/python-xyz.scm
parenta9722d0dbf03ad43156711ecd3ed4d21dfe649e1 (diff)
downloadpatches-957c683354a9c35c630dac16a1015b54d1909b81.tar
patches-957c683354a9c35c630dac16a1015b54d1909b81.tar.gz
gnu: python-mwclient: Update to 0.10.0.
* gnu/packages/python-xyz.scm (python-mwclient): Update to 0.10.0. [source]: Download using git-fetch. [propagated-inputs]: Remove python-requests. [native-inputs]: Remove python-pytest-pep8, python-pytest-cov. Add python-pytest-runner.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 72a72bbe50..475f37f3ef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12809,29 +12809,27 @@ exception message with a traceback that points to the culprit.")
(define-public python-mwclient
(package
(name "python-mwclient")
- (version "0.8.4")
+ (version "0.10.0")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; The PyPI version wouldn't contain tests.
- (uri (string-append "https://github.com/mwclient/mwclient/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/mwclient/mwclient")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1jj0yhilkjir00719fc7w133x7hdyhkxhk6xblla4asig45klsfv"))))
+ "1c3q6lwmb05yqywc4ya98ca7hsl15niili8rccl4n1yqp77c103v"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-requests" ,python-requests)
- ("python-requests-oauthlib"
- ,python-requests-oauthlib)
+ `(("python-requests-oauthlib" ,python-requests-oauthlib)
("python-six" ,python-six)))
(native-inputs
`(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)
- ("python-pytest-pep8" ,python-pytest-pep8)
- ("python-pytest-cache" ,python-pytest-cache)
("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)
("python-responses" ,python-responses)))
(home-page "https://github.com/btongminh/mwclient")
(synopsis "MediaWiki API client")