summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-16 23:11:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-16 23:22:12 +0100
commit86c7ca07aaf7c2af642089e00bcd9d0e7d64304d (patch)
treeaae8379d04461b50baeaa8ef5e75f45fe0c9c0fa /gnu/packages/python-xyz.scm
parentc70a019137a74a0013013e82594a9954b4f8a523 (diff)
downloadpatches-86c7ca07aaf7c2af642089e00bcd9d0e7d64304d.tar
patches-86c7ca07aaf7c2af642089e00bcd9d0e7d64304d.tar.gz
gnu: python-dask: Update to 2.9.0.
* gnu/packages/python-xyz.scm (python-dask): Update to 2.9.0. [arguments]: Adjust phase to disable broken tests. [propagated-inputs]: Add python-fsspec and python-packaging.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4a5f1a1289..aa75837e5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15915,38 +15915,38 @@ decisions with any given backend.")
(define-public python-dask
(package
(name "python-dask")
- (version "1.2.2")
+ (version "2.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dask" version))
(sha256
- (base32 "0b29gvf96gmp20wicly3v3mhyc93zbm3mdv935fka6x0wax7cy2y"))))
+ (base32 "1w1hqr8vyx6ygwflj2737dcy0mmgvrc0s602gnny8pzlcbs9m76b"))))
(build-system python-build-system)
- ;; A single test out of 5000+ fails. This test is marked as xfail when
- ;; pytest-xdist is used.
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-test
+ (add-after 'unpack 'disable-broken-tests
(lambda _
+ ;; This test is marked as xfail when pytest-xdist is used.
(substitute* "dask/tests/test_threaded.py"
(("def test_interrupt\\(\\)" m)
(string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
m)))
- (when (which "python2")
- ;; This test fails with recent Pandas:
- ;; <https://github.com/dask/dask/issues/3794>.
- (substitute* "dask/dataframe/tests/test_dataframe.py"
- (("def test_info\\(\\)" m)
- (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
- m))))
+ ;; This one fails with a type error:
+ ;; TypeError: Already tz-aware, use tz_convert to convert.
+ (substitute* "dask/dataframe/tests/test_shuffle.py"
+ (("def test_set_index_timestamp\\(\\)" m)
+ (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
+ m)))
#t))
(replace 'check
(lambda _ (invoke "pytest" "-vv"))))))
(propagated-inputs
`(("python-cloudpickle" ,python-cloudpickle)
+ ("python-fsspec" ,python-fsspec)
("python-numpy" ,python-numpy)
+ ("python-packaging" ,python-packaging)
("python-pandas" ,python-pandas)
("python-partd" ,python-partd)
("python-toolz" ,python-toolz)