summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-28 16:37:49 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-28 16:50:32 +0100
commit633c8b719913121f269fc654cd52be4870b5337e (patch)
tree2fde7b501f337ba844d971d01024605bd6eb89b3 /gnu/packages/python-xyz.scm
parent6c2c11fa103ff1990adcad8f1b8e6caaebeb304d (diff)
downloadpatches-633c8b719913121f269fc654cd52be4870b5337e.tar
patches-633c8b719913121f269fc654cd52be4870b5337e.tar.gz
gnu: python-waf: Add some extra tools.
* gnu/packages/python-xyz.scm (python-waf): Add gccdeps and clang_compilation_database tools that are needed by ardupilot.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6b0645376..37fc53536a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6346,7 +6346,12 @@ so it might be a tiny bit slower.")
(modify-phases %standard-phases
(replace 'build
(lambda _
- (invoke "python" "waf-light" "configure" "build")))
+ ;; XXX: Find a way to add all extra tools.
+ (let ((tools '("gccdeps"
+ "clang_compilation_database")))
+ (invoke "python" "waf-light" "configure" "build"
+ (string-append "--tools="
+ (string-join tools ","))))))
(replace 'check
(lambda _
(invoke "python" "waf" "--version")))