summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-06 08:58:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-06 08:58:54 +0200
commit11e46326e38c79734b694cd9483e12b2106f4d19 (patch)
treeb78fd27c82419b349e923a0121e9c06463708ea2 /gnu/packages/python-xyz.scm
parent1792a70655507625cbe654a0eec1428f210d2fd3 (diff)
downloadpatches-11e46326e38c79734b694cd9483e12b2106f4d19.tar
patches-11e46326e38c79734b694cd9483e12b2106f4d19.tar.gz
gnu: python-docopt: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-docopt)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db43bd72e4..af435e32ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
@@ -8063,15 +8063,15 @@ automatically detect a wide range of file encodings.")
(version "0.6.2")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; The release on PyPI does not include tests.
- (uri (string-append
- "https://github.com/docopt/docopt/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/docopt/docopt")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "16bf890xbdz3m30rsv2qacklh2rdn1zrfspfnwzx9g7vwz8yw4r1"))))
+ "0aad9gbswnnhssin2q0m5lmpm0ahyf80ahs2zjigbn5y7fvljnd0"))))
(build-system python-build-system)
(native-inputs
`(("python-pytest" ,python-pytest)))