summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-16 23:00:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-16 23:22:12 +0100
commitc70a019137a74a0013013e82594a9954b4f8a523 (patch)
tree613cfdc120f3a77fea4df3913bd303bccb589e73 /gnu/packages/python-xyz.scm
parent4ade2dd9d2c64912d6a57c05c799fa512c82dd5d (diff)
downloadpatches-c70a019137a74a0013013e82594a9954b4f8a523.tar
patches-c70a019137a74a0013013e82594a9954b4f8a523.tar.gz
gnu: Add python-fsspec.
* gnu/packages/python-xyz.scm (python-fsspec): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1c5c60f10..4a5f1a1289 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15890,6 +15890,28 @@ append on old values. Partd excels at shuffling operations.")
(define-public python2-partd
(package-with-python2 python-partd))
+(define-public python-fsspec
+ (package
+ (name "python-fsspec")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fsspec" version))
+ (sha256
+ (base32
+ "1g9ba8v04s1nrh7pvzfm2md7ivl2mrz3hcq3y9d1a44gd62h17zj"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; there are none
+ (home-page "https://github.com/intake/filesystem_spec")
+ (synopsis "File-system specification")
+ (description "The purpose of this package is to produce a template or
+specification for a file-system interface, that specific implementations
+should follow, so that applications making use of them can rely on a common
+behavior and not have to worry about the specific internal implementation
+decisions with any given backend.")
+ (license license:bsd-3)))
+
(define-public python-dask
(package
(name "python-dask")