summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-01 19:43:49 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-06 16:31:54 +0100
commit6a6b8a3fcfc35a5e7b10e7c2a9a75e909354d4d6 (patch)
tree936fd250284671c4231248320758598885224bfe /gnu/packages/python-xyz.scm
parent5757c641f2c547a45cb65f00a57af971381e6a42 (diff)
downloadpatches-6a6b8a3fcfc35a5e7b10e7c2a9a75e909354d4d6.tar
patches-6a6b8a3fcfc35a5e7b10e7c2a9a75e909354d4d6.tar.gz
gnu: python-py3status: Fix patch of file path
* gnu/packages/python-xyz.scm (python-py3status): Fix patch of file path. [arguments]: Replace single-quotes with double-quotes so that the regex matches again. The "replace-with" value is not changed as it's not necessary and would introduce escaping noise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c1a4f85f5..194d8b8b0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9912,7 +9912,7 @@ to occurrences in strings and comments.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((file-path (assoc-ref inputs "file")))
(substitute* "py3status/parse_config.py"
- (("\\['file', '-b'")
+ (("\\[\"file\", \"-b\"")
(string-append "['" file-path "/bin/file', '-b'")))
#t))))
#:tests? #f)) ; TODO: Requires many libraries not in Guix.