summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-20 04:57:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-20 20:42:39 +0100
commitdee92e65a239b2b0b3606a11d0fb3e0a5139ce79 (patch)
tree8a7372928e3a7dc3d616ae72309867241d611401 /gnu/packages/python-xyz.scm
parentc74da2b6c4ffeeff0c28eec74e4b27a8ad4bc420 (diff)
downloadpatches-dee92e65a239b2b0b3606a11d0fb3e0a5139ce79.tar
patches-dee92e65a239b2b0b3606a11d0fb3e0a5139ce79.tar.gz
gnu: python-colorspacious: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-colorspacious)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9617b1603..3ffe57aa15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3521,13 +3521,14 @@ To address this and enable easy cycling over arbitrary @code{kwargs}, the
(name "python-colorspacious")
(version "1.1.0")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/njsmith/colorspacious/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version))
- (sha256
- (base32 "1vflh5jm32qb0skza2i8pjacv09w6gq84fqpp2nj77s0rbmzgr4k"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/njsmith/colorspacious.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g0lxqiscy5g5rq9421vv7abg0c90jzy0zmas2z3hya6k2dr5aid"))))
(build-system python-build-system)
(propagated-inputs
`(("python-numpy" ,python-numpy)))