summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-17 18:24:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-19 00:01:49 +0100
commit32be357706c0667af2003fa875f06ef18957669d (patch)
tree9dd76bfaf019bab7c7caac4cd0d26397f4f8fd1f /gnu/packages/python-xyz.scm
parent217b4a1587e8b9af6526915a10e648f58234ebf0 (diff)
downloadpatches-32be357706c0667af2003fa875f06ef18957669d.tar
patches-32be357706c0667af2003fa875f06ef18957669d.tar.gz
gnu: python-dill: Update to 0.3.1.1.
* gnu/packages/python-xyz.scm (python-dill): Update to 0.3.1.1. [arguments]: Enable tests. [native-inputs]: Add python-nose. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f0490f248c..9075dfeb49 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15651,17 +15651,25 @@ object-oriented library such as @code{scikit-learn}.")
(define-public python-dill
(package
(name "python-dill")
- (version "0.2.9")
+ (version "0.3.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dill" version))
(sha256
- (base32 "0vwqyi6hyz2r29zydc78dqymkbc5y7gia16xcdh215cikxph9mpn"))))
+ (base32 "1704g8z70d210ksgbccs2v545v9w0wc6lx15m296alb7jf0yzn22"))))
(build-system python-build-system)
- ;; FIXME: The check phase fails with "don't know how to make test from: …".
- (arguments '(#:tests? #f))
- (home-page "https://pypi.org/project/dill")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "/tmp"
+ (invoke "nosetests" "-v"))
+ #t)))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://pypi.org/project/dill/")
(synopsis "Serialize all of Python")
(description "Dill extends Python's @code{pickle} module for serializing
and de-serializing Python objects to the majority of the built-in Python