summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-12 13:29:03 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-15 12:27:22 +0200
commit1130e8c8178386cf6d34c4ede7be0f5a9d30ad52 (patch)
tree76933ec89b6f6118367f9f1dffeaf95396106370 /gnu/packages/python-web.scm
parent35d1ac7fd805b4258bfb52091af7ac8c5628b27b (diff)
downloadpatches-1130e8c8178386cf6d34c4ede7be0f5a9d30ad52.tar
patches-1130e8c8178386cf6d34c4ede7be0f5a9d30ad52.tar.gz
gnu: Add python-selenium.
* gnu/packages/python-web.scm (python-selenium): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 88ba88e2e2..d64f698dbc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3746,3 +3746,26 @@ in Python with a focus on correctness and simplicity.
Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
it provides an elegant coroutine-based API.")
(license license:bsd-3)))
+
+(define-public python-selenium
+ (package
+ (name "python-selenium")
+ (version "3.141.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "selenium" version))
+ (sha256
+ (base32
+ "039hf9knvl4s3hp21bzwsp1g5ri9gxsh504dp48lc6nr1av35byy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-urllib3" ,python-urllib3)))
+ (home-page
+ "https://github.com/SeleniumHQ/selenium/")
+ (synopsis "Python bindings for Selenium")
+ (description "Selenium enables web browser automation.
+Selenium specifically provides infrastructure for the W3C WebDriver specification
+— a platform and language-neutral coding interface compatible with all
+major web browsers.")
+ (license license:asl2.0)))