summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-05-20 09:07:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-20 09:31:26 +0200
commita9daf35cb1cda8b8889ec7dc796079266709baec (patch)
tree7631e1cf8c4fa9e641ed016cfbbcf7833a5a71d7 /gnu/packages/python-web.scm
parent44935b2ebbde4b5bc73a06bfb2b544eca7244141 (diff)
downloadpatches-a9daf35cb1cda8b8889ec7dc796079266709baec.tar
patches-a9daf35cb1cda8b8889ec7dc796079266709baec.tar.gz
gnu: Add python-zope-deprecation.
* gnu/packages/python-web.scm (python-zope-deprecation): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0dff9610bc..dfdba6636b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3861,3 +3861,23 @@ actions. Instead of taking actions when a function (or class) decorator is
executed at import time, you can defer the action usually taken by the
decorator until a separate scan phase.")
(license license:repoze)))
+
+(define-public python-zope-deprecation
+ (package
+ (name "python-zope-deprecation")
+ (version "4.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "zope.deprecation" version))
+ (sha256
+ (base32
+ "1pz2cv7gv9y1r3m0bdv7ks1alagmrn5msm5spwdzkb2by0w36i8d"))))
+ (build-system python-build-system)
+ (native-inputs `())
+ (propagated-inputs `())
+ (home-page "https://zopedeprecation.readthedocs.io/")
+ (synopsis "Function for marking deprecations")
+ (description "The @code{zope.deprecation} module provides a function for
+marking modules, classes, functions, methods and properties as deprecated,
+displaying warnings when usaged in application code.")
+ (license license:zpl2.1)))