summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-05-20 09:07:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-20 09:26:29 +0200
commit44935b2ebbde4b5bc73a06bfb2b544eca7244141 (patch)
tree86a694cf45c5886d8e433e613ebc42da7d0335df /gnu/packages/python-web.scm
parent712190edeae0d9e1c2e94abaab120676dd5dfa7d (diff)
downloadpatches-44935b2ebbde4b5bc73a06bfb2b544eca7244141.tar
patches-44935b2ebbde4b5bc73a06bfb2b544eca7244141.tar.gz
gnu: Add python-venusian.
* gnu/packages/python-web.scm (python-venusian): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a554f598e2..0dff9610bc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3836,3 +3836,28 @@ major web browsers.")
(synopsis "Python wrapper around rapidjson")
(description "This package provides a python wrapper around rapidjson.")
(license license:expat)))
+
+(define-public python-venusian
+ (package
+ (name "python-venusian")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "venusian" version))
+ (sha256
+ (base32 "0f7f67dkgxxcjfhpdd5frb9pszkf04lyzzpn5069q0xi89r2p17n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-runner" ,python-pytest-runner)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (arguments '(#:test-target "pytest"))
+ (home-page "https://docs.pylonsproject.org/projects/venusian")
+ (synopsis "Library for defering decorator actions")
+ (description
+ "Venusian is a library which allows framework authors to defer decorator
+actions. Instead of taking actions when a function (or class) decorator is
+executed at import time, you can defer the action usually taken by the
+decorator until a separate scan phase.")
+ (license license:repoze)))