summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-05-04 02:42:15 +1000
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-05 14:44:20 +0200
commit7a82ceb7bb749e5590c82ea31985497271df26a0 (patch)
treeeecc887b915eb7d7694a05dc0ed30893556c2ee5 /gnu/packages/python-web.scm
parent13068a8ccf68653f082728b8809c46970cb97f60 (diff)
downloadpatches-7a82ceb7bb749e5590c82ea31985497271df26a0.tar
patches-7a82ceb7bb749e5590c82ea31985497271df26a0.tar.gz
gnu: Add python-html2text, python2-html2text.
* gnu/packages/python-web.scm (python-html2text): New variable. (python2-html2text): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 37da0fd669..839d444f7c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -299,6 +299,28 @@ other HTTP libraries.")
(define-public python2-httplib2
(package-with-python2 python-httplib2))
+(define-public python-html2text
+ (package
+ (name "python-html2text")
+ (version "2018.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "html2text" version))
+ (sha256
+ (base32
+ "1m6d7ciq30adc3d1n8g6r46072n7q8kdy039pqvnnmp763xi8xb2"))))
+ (build-system python-build-system)
+ (home-page "https://pypi.org/project/html2text/")
+ (synopsis "Convert HTML into plain text")
+ (description "html2text takes HTML and converts it into plain ASCII text
+which is also valid markdown. html2text was originally written by Aaron
+Swartz.")
+ (license license:gpl3+)))
+
+(define-public python2-html2text
+ (package-with-python2 python-html2text))
+
(define-public python-mechanicalsoup
(package
(name "python-mechanicalsoup")