summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-10-29 16:14:13 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-30 17:53:11 +0100
commit93953ec714d2f36ac6862e3965e8a07b531ffa35 (patch)
tree1c05993f99d6c628ac2e12ef1200711345888912 /gnu/packages/python-crypto.scm
parent08db81c95a9aab385524acdff22904a0d4442ce4 (diff)
downloadpatches-93953ec714d2f36ac6862e3965e8a07b531ffa35.tar
patches-93953ec714d2f36ac6862e3965e8a07b531ffa35.tar.gz
gnu: Add python-keyutils.
* gnu/packages/python-crypto.scm (python-keyutils): New variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index f05c01060f..7dac25eb61 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1062,3 +1063,30 @@ Password-Authenticated Key Exchange algorithm.")
(description "This package provides a Twisted-based Tor controller client,
with state-tracking and configuration abstractions.")
(license license:expat)))
+
+(define-public python-keyutils
+ (package
+ (name "python-keyutils")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "keyutils" version))
+ (sha256
+ (base32
+ "0lipygpzhwzzsq2k5imb1jgkmj8y4khxdwhzadjs3bd56g6bmkx9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (inputs
+ `(("keyutils" ,keyutils)))
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://github.com/sassoftware/python-keyutils")
+ (synopsis "Python bindings for keyutils")
+ (description
+ "This is a set of python bindings for keyutils, a key management suite
+that leverages the infrastructure provided by the Linux kernel for safely
+storing and retrieving sensitive infromation in your programs.")
+ (license license:asl2.0)))