summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-12 22:37:23 -0400
committerLeo Famulari <leo@famulari.name>2017-04-12 22:47:34 -0400
commit2e3744730777dc4e988675be369692d2be6fa1e2 (patch)
tree9c086f933c691b445f9b3987c7d9fb3832d25c42 /gnu/packages/pulseaudio.scm
parentefc95e7bc6bfd97425b9f2fdb5eebac6b99aac6b (diff)
downloadpatches-2e3744730777dc4e988675be369692d2be6fa1e2.tar
patches-2e3744730777dc4e988675be369692d2be6fa1e2.tar.gz
gnu: libsndfile: Update to 1.0.28 [fixes CVE-2017-{7585,7586,7741,7742}].
* gnu/packages/pulseaudio.scm (libsndfile)[replacement]: New field. (libsndfile-1.0.28): New variable.
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index e306bdf3ad..71fcc3f827 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -43,6 +43,7 @@
(define-public libsndfile
(package
(name "libsndfile")
+ (replacement libsndfile-1.0.28)
(version "1.0.27")
(source (origin
(method url-fetch)
@@ -73,6 +74,19 @@ SPARC. Hopefully the design of the library will also make it easy to extend
for reading and writing new sound file formats.")
(license l:gpl2+)))
+(define libsndfile-1.0.28
+ (package
+ (inherit libsndfile)
+ (version "1.0.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))))
+
(define-public libsamplerate
(package
(name "libsamplerate") ; aka. Secret Rabbit Code (SRC)