summaryrefslogtreecommitdiff
path: root/gnu/packages/printers.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
commit3b458d5462e6bbd852c2dc5c6670d5655abf53f5 (patch)
tree4f3ccec0de1c355134369333c17e948e3258d546 /gnu/packages/printers.scm
parent2ca3fdc2db1aef96fbf702a2f26f5e18ce832038 (diff)
parent14da3daafc8dd92fdabd3367694c930440fd72cb (diff)
downloadpatches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar
patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/printers.scm')
-rw-r--r--gnu/packages/printers.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index dff9ed3010..2d608bf3cb 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,9 +21,13 @@
(define-module (gnu packages printers)
#:use-module (guix packages)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages cups)
#:use-module (gnu packages libusb)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt))
@@ -68,3 +73,54 @@
with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
(home-page "http://robocut.org")
(license license:gpl3+)))
+
+(define-public brlaser
+ (let ((commit "779f71e80fcc583f4537c844de141cf8e6a738fe")
+ (revision "1"))
+ (package
+ (name "brlaser")
+ (version (git-version "4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdewacht/brlaser.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yrz9706660hdfi2y0ndp254r0vw9y665hwmxbbzfnz4ai13vj50"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCUPS_DATA_DIR="
+ (assoc-ref %outputs "out")
+ "/share/cups")
+ (string-append "-DCUPS_SERVER_BIN="
+ (assoc-ref %outputs "out")
+ "/lib/cups"))))
+ (inputs
+ `(("ghostscript" ,ghostscript)
+ ("cups" ,cups)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/pdewacht/brlaser")
+ (synopsis "Brother laser printer driver")
+ (description "Brlaser is a CUPS driver for Brother laser printers. This
+driver is known to work with these printers:
+
+@enumerate
+@item Brother DCP-1510
+@item Brother DCP-7030
+@item Brother DCP-7040
+@item Brother DCP-7055
+@item Brother DCP-7055W
+@item Brother DCP-7065DN
+@item Brother DCP-7080
+@item Brother HL-1200 series
+@item Brother HL-L2320D series
+@item Brother HL-L2360D series
+@item Brother MFC-7240
+@item Brother MFC-7360N
+@end enumerate
+
+It partially works with printers from the Brother HL-L2300D series.")
+ (license license:gpl2+))))