aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-24 21:26:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-24 21:26:58 +0100
commit9a6b8c9fa36bca5541336d61685ebdea10654ce4 (patch)
treeb42a107e88f9d9d127e5fe16bbbcb4b71f7446f8 /gnu/packages/popt.scm
parent4e3a7d84613e4caeca903a205f21707cff5819f7 (diff)
parentaa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc (diff)
downloadpatches-9a6b8c9fa36bca5541336d61685ebdea10654ce4.tar
patches-9a6b8c9fa36bca5541336d61685ebdea10654ce4.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index 5da2bb1d3f..e3f5fa1895 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +21,7 @@
(define-module (gnu packages popt)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix licenses))
@@ -96,15 +97,16 @@ similar to getopt(3), it contains a number of enhancements, including:
(define-public gflags
(package
(name "gflags")
- (version "2.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/gflags/gflags"
- "/archive/v" version ".tar.gz"))
- (sha256
- (base32
- "03lxc2ah8i392kh1naq99iip34k4fpv22kwflyx3byd2ssycs9xf"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (version "2.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gflags/gflags.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "147i3md3nxkjlrccqg4mq1kyzc7yrhvqv5902iibc7znkvzdvlp0"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON"