summaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 01:13:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 01:13:18 +0100
commit98ca002aaf14b38ae3445e801d497177888f8438 (patch)
treec22318b1c88a66bff023d1297e5efcc4949b0508 /gnu/packages/popt.scm
parent574a71a7a9668aa184661c58e1f18a4d4fccd792 (diff)
downloadpatches-98ca002aaf14b38ae3445e801d497177888f8438.tar
patches-98ca002aaf14b38ae3445e801d497177888f8438.tar.gz
gnu: popt: Reverse source mirror entries.
Commit 8f4cff0e21e4142d5f51022ef1efad569c3ca0bc accidentally caused rebuilds because the expected file name changed. * gnu/packages/popt.scm (popt)[source](uri): Add the Debian mirror last.
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index 6346c54f22..857455d213 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -62,13 +62,12 @@ line syntax.")
(version "1.16")
(source (origin
(method url-fetch)
- ;; The rpm5.org domain does not resolve since 2019-06-13, so we
- ;; borrow Debians infrastructure for the source download.
- (uri (list (string-append "https://deb.debian.org/debian/pool/main"
- "/p/popt/popt_" version ".orig.tar.gz")
- ;; Keep the old URL around in case it reappears.
- (string-append "http://rpm5.org/files/popt/popt-"
- version ".tar.gz")))
+ (uri (list (string-append "http://rpm5.org/files/popt/popt-"
+ version ".tar.gz")
+ ;; The rpm5.org domain does not resolve since 2019-06-13,
+ ;; so fallback to Debians copy.
+ (string-append "https://deb.debian.org/debian/pool/main"
+ "/p/popt/popt_" version ".orig.tar.gz")))
(sha256
(base32
"1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))