summaryrefslogtreecommitdiff
path: root/gnu/packages/popt.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-31 16:28:51 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-01 11:39:33 +0200
commit9495e73689b4d650146523830ee2da164fc50448 (patch)
tree3e608c86192c6acc278ffba8a1503ccbafb72a18 /gnu/packages/popt.scm
parentf6e7e20b03daba53cc63edd0661b2f4ead722f26 (diff)
downloadpatches-9495e73689b4d650146523830ee2da164fc50448.tar
patches-9495e73689b4d650146523830ee2da164fc50448.tar.gz
gnu: Add argtable.
* gnu/packages/popt.scm (argtable): New variable.
Diffstat (limited to 'gnu/packages/popt.scm')
-rw-r--r--gnu/packages/popt.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index 9ccca5c8b5..7739c7a276 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,34 @@
#:use-module (guix build-system gnu)
#:use-module (guix licenses))
+(define-public argtable
+ (package
+ (name "argtable")
+ (version "2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/argtable/argtable"
+ (string-join (string-split version #\.) "-")
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1gyxf4bh9jp5gb3l6g5qy90zzcf3vcpk0irgwbv1lc6mrskyhxwg"))))
+ (build-system gnu-build-system)
+ (home-page "http://argtable.sourceforge.net/")
+ (synopsis "Command line option parsing library")
+ (description
+ "Argtable is an ANSI C library for parsing GNU style command line
+options. It enables a program's command line syntax to be defined in the
+source code as an array of argtable structs. The command line is then parsed
+according to that specification and the resulting values are returned in those
+same structs where they are accessible to the main program. Both tagged (-v,
+--verbose, --foo=bar) and untagged arguments are supported, as are multiple
+instances of each argument. Syntax error handling is automatic and the library
+also provides the means for generating a textual description of the command
+line syntax.")
+ (license lgpl2.0+)))
+
(define-public popt
(package
(name "popt")