summaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-14 17:37:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-14 17:37:20 +0100
commit8c72ed923d77ee55989965bb02628043799b9548 (patch)
tree802e6eb910719a98fa09bf7c2bd884097f649adc /gnu/packages/polkit.scm
parent189be331acfda1c242a9c85fca8d2a0356742f48 (diff)
parentaac6cbbfede0bbfafdbbeeb460f00a244333895d (diff)
downloadpatches-8c72ed923d77ee55989965bb02628043799b9548.tar
patches-8c72ed923d77ee55989965bb02628043799b9548.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 0e38dd61ee..a3dbc4ff79 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,7 +78,8 @@
;; Set the setuid helper's real location.
(substitute* "src/polkitagent/polkitagentsession.c"
(("PACKAGE_PREFIX \"/lib/polkit-1/polkit-agent-helper-1\"")
- "\"/run/setuid-programs/polkit-agent-helper-1\""))))))
+ "\"/run/setuid-programs/polkit-agent-helper-1\""))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("expat" ,expat)
@@ -105,7 +107,8 @@
(("@INTROSPECTION_GIRDIR@")
(string-append out "/share/gir-1.0/"))
(("@INTROSPECTION_TYPELIBDIR@")
- (string-append out "/lib/girepository-1.0/"))))))
+ (string-append out "/lib/girepository-1.0/")))
+ #t)))
(replace
'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
@@ -113,13 +116,13 @@
;; to install in /etc, and to instead install the skeletons in the
;; output directory.
(let ((out (assoc-ref outputs "out")))
- (zero? (apply system*
- "make" "install"
+ (apply invoke "make" "install"
(string-append "sysconfdir=" out "/etc")
(string-append "polkit_actiondir="
out "/share/polkit-1/actions")
- make-flags))))))))
- (home-page "http://www.freedesktop.org/wiki/Software/polkit/")
+ make-flags)
+ #t))))))
+ (home-page "https://www.freedesktop.org/wiki/Software/polkit/")
(synopsis "Authorization API for privilege management")
(description "Polkit is an application-level toolkit for defining and
handling the policy that allows unprivileged processes to speak to
@@ -183,5 +186,5 @@ easily with PolicyKit.")
(description "PolicyKit-gnome provides a D-Bus session bus service
that is used to bring up authentication dialogs used for obtaining
privileges.")
- (home-page "http://www.freedesktop.org/wiki/Software/polkit/")
+ (home-page "https://www.freedesktop.org/wiki/Software/polkit/")
(license lgpl2.0+)))