summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-20 22:12:10 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-20 22:12:10 +0100
commit3e2d4e69c340c3520f546f8c7e21e52383058d1c (patch)
tree0bc92edb753cfdf9a9e7ef763ebc19f0cd2d528c /gnu/packages/php.scm
parentad79ae7e2d7505292b11e87302b08f4db0f934e9 (diff)
parente5ad2cdf172eecc7edef37a500593b1941af013c (diff)
downloadpatches-3e2d4e69c340c3520f546f8c7e21e52383058d1c.tar
patches-3e2d4e69c340c3520f546f8c7e21e52383058d1c.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index a96f1c2259..392ac92430 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages dbm)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
@@ -42,6 +43,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
@@ -56,7 +58,7 @@
(define-public php
(package
(name "php")
- (version "7.3.0")
+ (version "7.3.1")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -64,7 +66,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
+ "0qikydmjg8k68l56azq4vg3gkynqwlpzayd5qi9wsl03pr03xsfg"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -222,6 +224,12 @@
;; This bug should have been fixed in gd 2.2.2.
;; Is it a regression?
"ext/gd/tests/bug65148.phpt"
+ ;; These tests should not be run (disabled because
+ ;; GD_BUNDLED = 0)
+ "ext/gd/tests/bug77198_auto.phpt"
+ "ext/gd/tests/bug77198_threshold.phpt"
+ "ext/gd/tests/bug77200.phpt"
+ "ext/gd/tests/bug77269.phpt"
;; TODO: Enable these when libgd is built with xpm support.
"ext/gd/tests/xpm2gd.phpt"
"ext/gd/tests/xpm2jpg.phpt"
@@ -287,6 +295,10 @@
"ext/mbstring/tests/mb_ereg_variation3.phpt"
"ext/mbstring/tests/mb_ereg_replace_variation1.phpt"
"ext/mbstring/tests/bug72994.phpt"
+ "ext/mbstring/tests/bug77367.phpt"
+ "ext/mbstring/tests/bug77370.phpt"
+ "ext/mbstring/tests/bug77371.phpt"
+ "ext/mbstring/tests/bug77381.phpt"
"ext/ldap/tests/ldap_set_option_error.phpt"
;; Sometimes cannot start the LDAP server.