summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
commit3b458d5462e6bbd852c2dc5c6670d5655abf53f5 (patch)
tree4f3ccec0de1c355134369333c17e948e3258d546 /gnu/packages/php.scm
parent2ca3fdc2db1aef96fbf702a2f26f5e18ce832038 (diff)
parent14da3daafc8dd92fdabd3367694c930440fd72cb (diff)
downloadpatches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar
patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 8d96e54c90..45dd2bdd3a 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -58,7 +58,7 @@
(define-public php
(package
(name "php")
- (version "7.3.3")
+ (version "7.3.4")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -66,7 +66,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1cxrpaz5cvx1qq9klwgvcyvcly865sxpn4bdk82wpl43l5wkxc3b"))
+ "10rvj9dn41213w0q2l123rn6sycr29syik88czprhpv5z2hrzrvg"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -86,7 +86,7 @@
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
+ `(#:configure-flags
(let-syntax ((with (syntax-rules ()
((_ option input)
(string-append option "="
@@ -182,6 +182,20 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
+ ,@(if (string-prefix? "arm" (or (%current-system)
+ (%current-target-system)))
+ ;; Drop tests known to fail on armhf.
+ '((for-each delete-file
+ (list
+ "ext/calendar/tests/unixtojd_error1.phpt"
+ ;; arm can be a lot slower, so a time-related test fails
+ "ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
+ "ext/pcre/tests/bug76514.phpt"
+ "ext/pcre/tests/preg_match_error3.phpt"
+ "ext/standard/tests/general_functions/var_export-locale.phpt"
+ "ext/standard/tests/general_functions/var_export_basic1.phpt")))
+ '())
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.