summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-05-25 00:12:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-25 00:17:18 +0200
commit8bd0b533b30d7ee5e03aee99a2eb96d5b0b1c836 (patch)
treefdab66886f61669eea998da99f0b03553965015e /gnu/packages/photo.scm
parente451612602c5ae8bca1e56492bbfa7b2fe434cbd (diff)
downloadpatches-8bd0b533b30d7ee5e03aee99a2eb96d5b0b1c836.tar
patches-8bd0b533b30d7ee5e03aee99a2eb96d5b0b1c836.tar.gz
gnu: libexif: Update to 0.6.22 [security fixes].base-for-series-4085
This fixes CVE-2020-13114, CVE-2020-13113, CVE-2020-13112, CVE-2020-0093, CVE-2019-9278, and CVE-2020-12767. * gnu/packages/patches/libexif-CVE-2016-6328.patch, gnu/packages/patches/libexif-CVE-2017-7544.patch, gnu/packages/patches/libexif-CVE-2018-20030.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/photo.scm (libexif): Update to 0.6.22. [source](uri): Adjust for upstream GitHub migration.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index dfd45fd06b..4904fa1db1 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -206,17 +206,17 @@ cameras (CRW/CR2, NEF, RAF, DNG, and others).")
(define-public libexif
(package
(name "libexif")
- (version "0.6.21")
+ (version "0.6.22")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/libexif/libexif/"
- version "/libexif-" version ".tar.bz2"))
- (patches (search-patches "libexif-CVE-2016-6328.patch"
- "libexif-CVE-2017-7544.patch"
- "libexif-CVE-2018-20030.patch"))
+ (uri (string-append
+ "https://github.com/libexif/libexif/releases"
+ "/download/libexif-"
+ (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+ "-release/libexif-" version ".tar.xz"))
(sha256
(base32
- "06nlsibr3ylfwp28w8f5466l6drgrnydgxrm4jmxzrmk5svaxk8n"))))
+ "0mhcad5zab7fsn120rd585h8ncwkq904nzzrq8vcd72hzk4g2j2h"))))
(build-system gnu-build-system)
(home-page "https://libexif.github.io/")
(synopsis "Read and manipulate EXIF data in digital photographs")