summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-06-15 09:15:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-06-15 09:18:25 +0300
commit4dbef2397f05493e1d59f3112cda94729f5968b5 (patch)
tree610c83b79bad0e220b77fddb070043607501c72b /gnu/packages/photo.scm
parent007993bf0bfc8c7357d0f9ac0be2dd92d46130c1 (diff)
downloadpatches-4dbef2397f05493e1d59f3112cda94729f5968b5.tar
patches-4dbef2397f05493e1d59f3112cda94729f5968b5.tar.gz
gnu: lensfun: Fix building on non-Intel machines.
* gnu/packages/photo.scm (lensfun)[arguments]: On non-Intel machines, don't build with architecture specific instructions.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 1fae0e4a7c..92513822ce 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -54,7 +54,9 @@
#:use-module (gnu packages tex)
#:use-module (gnu packages web)
#:use-module (gnu packages xfig)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26))
(define-public libraw
(package
@@ -285,7 +287,14 @@ scene to produce an image that looks much like a tone-mapped image.")
(base32
"0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; There are no tests to run.
+ (arguments
+ `(,@(if (any (cute string-prefix? <> (or (%current-system)
+ (%current-target-system)))
+ '("x86_64" "i686"))
+ ;; SSE and SSE2 are supported only on Intel processors.
+ '()
+ '(#:configure-flags '("-DBUILD_FOR_SSE=OFF" "-DBUILD_FOR_SSE2=OFF")))
+ #:tests? #f)) ; There are no tests to run.
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs