summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-04 19:26:07 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-04 21:30:00 +0200
commit341f49657784d55f7e3207d00bdfd26a367a332c (patch)
treee5f727b5ec075f831fb26c307c3480507eff62b8 /gnu/packages/photo.scm
parent34582b303719bd1f305a2a565285ee19e65a4706 (diff)
downloadpatches-341f49657784d55f7e3207d00bdfd26a367a332c.tar
patches-341f49657784d55f7e3207d00bdfd26a367a332c.tar.gz
gnu: Add prefix to license imports in (gnu packages photo).
* gnu/packages/photo.scm: Import (guix licenses) with #:prefix license: to avoid an impending clash with the import of zlib from both (guix licenses) and (gnu packages compression).
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index cbfc1e8730..4dba088fdd 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,7 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages photo)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -48,7 +49,7 @@
(description
"LibRaw is a library for reading RAW files obtained from digital photo
cameras (CRW/CR2, NEF, RAF, DNG, and others).")
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public libexif
(package
@@ -67,7 +68,7 @@ cameras (CRW/CR2, NEF, RAF, DNG, and others).")
(description
"The libexif C library allows applications to read, edit, and save EXIF
data as produced by digital cameras.")
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public libgphoto2
(package
@@ -97,7 +98,7 @@ MTP, and other vendor specific protocols for controlling and transferring data
from digital cameras.")
;; 'COPYING' says LGPLv2.1+, but in practices files are under LGPLv2+.
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public gphoto2
(package
@@ -140,7 +141,7 @@ number of different digital cameras. Through libgphoto2, it supports PTP,
MTP, and much more.")
;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+.
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public perl-image-exiftool
(package