summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-05 18:41:27 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-06 18:20:01 +0200
commit0e6412c1d0465a6b3260f4855f3aad76b8b475e6 (patch)
tree5737cdddaa497ecdf20ffe9d2e6277d360e17f9a /gnu/packages/photo.scm
parenta5c0d8bc557affbcb58a4d2cb0059604e0cb89fa (diff)
downloadpatches-0e6412c1d0465a6b3260f4855f3aad76b8b475e6.tar
patches-0e6412c1d0465a6b3260f4855f3aad76b8b475e6.tar.gz
gnu: Add libpano13.
* gnu/packages/photo.scm (libpano13): New variable.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 38417e3781..3ecb1d720c 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -19,6 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages photo)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix download)
@@ -26,6 +27,8 @@
#:use-module (guix packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libusb)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -175,3 +178,29 @@ MTP, and much more.")
"This package provides the 'exiftool' command and the 'Image::ExifTool'
Perl library to manipulate EXIF tags of digital images.")
(license (package-license perl))))
+
+(define-public libpano13
+ (package
+ (name "libpano13")
+ (version "2.9.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/panotools/libpano13/"
+ "libpano13-" version "/"
+ "libpano13-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1a4m3plmfcrrplqs9zfzhc5apibn10m5sajpizm1sd3q74w5fwq3"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("zlib" ,zlib)))
+ (home-page "http://panotools.sourceforge.net/")
+ (synopsis "Library for panoramic images")
+ (description
+ "The libpano13 package contains the backend library written by the
+Panorama Tools project for building panoramic images from a set of
+overlapping images, as well as some command line tools.")
+ (license license:gpl2+)))