summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 12:23:59 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 16:37:28 +0100
commit3def739da13a166769777d0db7baba79230f64ae (patch)
tree32971aa5389fcdf8fe4de53790bd14e3a63aeffb /gnu/packages/photo.scm
parentc695fb769c94623371c5997da1dc454b0a4f58a8 (diff)
downloadpatches-3def739da13a166769777d0db7baba79230f64ae.tar
patches-3def739da13a166769777d0db7baba79230f64ae.tar.gz
gnu: Use the CMake build system's #:build-type key.
* gnu/packages/code.scm (rtags)[arguments]: Move the CMAKE_BUILD_TYPE from #:configure-flags to #:build-type. * gnu/packages/databases.scm (apache-arrow)[arguments]: Likewise * gnu/packages/engineering.scm (kicad)[arguments]: Likewise * gnu/packages/flashing-tools.scm (heimdall)[arguments]: Likewise * gnu/packages/graphics.scm (openscenegraph)[arguments]: Likewise * gnu/packages/linux.scm (rdma-core)[arguments]: Likewise * gnu/packages/music.scm (portmidi)[arguments]: Likewise * gnu/packages/photo.scm (rawtherapee)[arguments]: Likewise * gnu/packages/rdesktop.scm (freerdp)[arguments]: Likewise * gnu/packages/serialization.scm (flatbuffers)[arguments]: Likewise * gnu/packages/web.scm (tidy-html)[arguments]: Likewise
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 758ed3f6f1..90bc365d05 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -481,11 +481,11 @@ a complete panorama and stitch any series of overlapping pictures.")
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no test suite
+ #:build-type "release"
#:configure-flags
(list (string-append "-DLENSFUNDBDIR="
(assoc-ref %build-inputs "lensfun")
"/share/lensfun")
- "-DCMAKE_BUILD_TYPE=release"
; Don't optimize the build for the host machine. See the file
; 'ProcessorTargets.cmake' in the source distribution for more
; information.