summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-15 21:07:26 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-16 20:42:27 -0400
commit32315df9c70587bbf5d2fd414c9dd2def7b7685a (patch)
tree815bddf9663e95227a7aabd070cd7e885de7a08f /gnu/packages/perl.scm
parent52b1551bff9befe12c13bfe7c9f2d0fa5810b455 (diff)
downloadpatches-32315df9c70587bbf5d2fd414c9dd2def7b7685a.tar
patches-32315df9c70587bbf5d2fd414c9dd2def7b7685a.tar.gz
gnu: Add perl-file-finder.
* gnu/packages/perl.scm (perl-file-finder): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4974d7e9d8..7d5c834d67 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9530,6 +9530,38 @@ File::Find replacement in Perl.")
interface to File::Find::Object.")
(license (package-license perl))))
+(define-public perl-file-finder
+ (package
+ (name "perl-file-finder")
+ (version "0.53")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/ME/MERLYN/File-Finder-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x3a2xgzrka73lcmmwalq2mmpzxa7s6pm01ahxf677ksqsdc3jrf"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-text-glob" ,perl-text-glob)))
+ (home-page "http://search.cpan.org/dist/File-Finder/")
+ (synopsis "Wrapper for @code{File::Find} ala @code{find(1)}")
+ (description
+ "@code{File::Find} is great, but constructing the wanted routine can
+sometimes be a pain. @code{File::Finder} provides a wanted-writer, using
+syntax that is directly mappable to the @code{find(1)} command's syntax.
+
+A @code{File::Finder} object contains a hash of @code{File::Find} options, and
+a series of steps that mimic find's predicates. Initially, a
+@code{File::Finder} object has no steps. Each step method clones the previous
+object's options and steps, and then adds the new step, returning the new
+object. In this manner, an object can be grown, step by step, by chaining
+method calls. Furthermore, a partial sequence can be created and held, and
+used as the head of many different sequences.")
+ (license perl-license)))
+
(define-public perl-font-ttf
(package
(name "perl-font-ttf")