summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 11:56:47 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commit393ca946219ed6bc84d6d27b7c68ada18f71e5bd (patch)
treee88614e8c3f7a9a8fbfb6fb8c7c9f12ae70a7620 /gnu/packages/perl.scm
parent5a96dc03c73ad533c4a22eaf3044dccd24a526c8 (diff)
downloadpatches-393ca946219ed6bc84d6d27b7c68ada18f71e5bd.tar
patches-393ca946219ed6bc84d6d27b7c68ada18f71e5bd.tar.gz
gnu: Add Scope-Guard.
* gnu/packages/perl.scm (perl-scope-guard): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e72614786f..e166ae04e7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2439,6 +2439,30 @@ codes.")
safely on things that may not be objects.")
(license (package-license perl))))
+(define-public perl-scope-guard
+ (package
+ (name "perl-scope-guard")
+ (version "0.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CH/CHOCOLATE/"
+ "Scope-Guard-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lsagnz6pli035zvx5c1x4qm9fabi773vns86yd8lzfpldhfv3sv"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Scope-Guard")
+ (synopsis "Lexically-scoped resource management")
+ (description "This module provides a convenient way to perform cleanup or
+other forms of resource management at the end of a scope. It is particularly
+useful when dealing with exceptions: the Scope::Guard constructor takes a
+reference to a subroutine that is guaranteed to be called even if the thread
+of execution is aborted prematurely. This effectively allows lexically-scoped
+\"promises\" to be made that are automatically honoured by perl's garbage
+collector.")
+ (license (package-license perl))))
+
(define-public perl-stream-buffered
(package
(name "perl-stream-buffered")