summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-06-29 15:51:24 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-02 16:24:35 +0200
commit4ca06e4c87ad35a3b4b03c381a97171c37201b6e (patch)
treebcb604cb1148f2d574287897e8ab1cd4bbdf1d55 /gnu/packages/perl.scm
parent77ff12c98738aedcb7f54a8ba8bfd3ddacc0b83f (diff)
downloadpatches-4ca06e4c87ad35a3b4b03c381a97171c37201b6e.tar
patches-4ca06e4c87ad35a3b4b03c381a97171c37201b6e.tar.gz
gnu: Add perl-mixin-linewise.
* gnu/packages/perl.scm (perl-mixin-linewise): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c62c79acaa..7389b5e1eb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2979,6 +2979,31 @@ from various sources. For instance, it contains all IANA types and the
knowledge of Apache.")
(license (package-license perl))))
+(define-public perl-mixin-linewise
+ (package
+ (name "perl-mixin-linewise")
+ (version "0.108")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RJ/RJBS/Mixin-Linewise-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1wmfr19w9y8qys7b32mnj1vmps7qwdahqas71a9p62ac8xw0dwkx"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-perlio-utf8_strict" ,perl-perlio-utf8_strict)
+ ("perl-sub-exporter" ,perl-sub-exporter)))
+ (home-page "http://search.cpan.org/dist/Mixin-Linewise")
+ (synopsis "Write your linewise code for handles; this does the rest")
+ (description "It's boring to deal with opening files for IO, converting
+strings to handle-like objects, and all that. With
+@code{Mixin::Linewise::Readers} and @code{Mixin::Linewise::Writers}, you can
+just write a method to handle handles, and methods for handling strings and
+file names are added for you.")
+ (license (package-license perl))))
+
(define-public perl-module-build-tiny
(package
(name "perl-module-build-tiny")