summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-07-05 16:12:23 +0200
committerRoel Janssen <roel@gnu.org>2016-07-05 16:12:23 +0200
commit091963c69b517a97aaf2cad62e700ecb6c855a93 (patch)
treead81aa30a4bc12bbabea1bd249fedba7758e2efd /gnu/packages/perl.scm
parent1f1b20b8bec64b5297769d57db5cf4855b6b80e2 (diff)
downloadpatches-091963c69b517a97aaf2cad62e700ecb6c855a93.tar
patches-091963c69b517a97aaf2cad62e700ecb6c855a93.tar.gz
gnu: Add perltidy.
* gnu/packages/perl.scm (perltidy): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c171af482a..aed2a61320 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6068,6 +6069,26 @@ system.")
as exceptions to standard program flow.")
(license (package-license perl))))
+(define-public perltidy
+ (package
+ (name "perltidy")
+ (version "20160302")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/perltidy/Perl-Tidy-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "19yw63yh5s3pq7k3nkw6nsamg5b8vvwyhgbizslgxg0mqgc4xl3d"))))
+ (build-system perl-build-system)
+ (home-page "http://perltidy.sourceforge.net/")
+ (synopsis "Perl script tidier")
+ (description "This package contains a Perl script which indents and
+reformats Perl scripts to make them easier to read. The formatting can be
+controlled with command line parameters. The default parameter settings
+approximately follow the suggestions in the Perl Style Guide.")
+ (license gpl2+)))
+
(define-public perl-tie-ixhash
(package
(name "perl-tie-ixhash")