summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-21 21:34:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 21:34:41 +0100
commit715110a8a2e9e4b1a89635950744eb5260b8ee7f (patch)
tree0d0e4c41631092a068d8b0823f4d6b0a8d725eed /gnu/packages/perl.scm
parentb3c2ebda5bcedcfb88475e53b7f36c3a42cac8b4 (diff)
parent79e074ea10875ff75ca613179c70de12d64b19f5 (diff)
downloadpatches-715110a8a2e9e4b1a89635950744eb5260b8ee7f.tar
patches-715110a8a2e9e4b1a89635950744eb5260b8ee7f.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c94afbc4b9..13f038d466 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -52,10 +52,12 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages less)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-compression)
#:use-module (gnu packages perl-web)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages textutils))
;;;
@@ -8491,6 +8493,40 @@ other terminal related features, including retrieval/modification of the
screen size, and retrieval/modification of the control characters.")
(license (package-license perl))))
+(define-public perl-term-readline-gnu
+ (package
+ (name "perl-term-readline-gnu")
+ (version "1.36")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAYASHI/"
+ "Term-ReadLine-Gnu-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09b9mcmp09kdfh5jaqdr528yny8746hvn3f185aqd6rw06jgf24s"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("readline" ,readline)
+ ("ncurses" ,ncurses)))
+ (arguments
+ `(#:tests? #f ; Tests fail without other Term::ReadLine interfaces present
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'patch-search-lib
+ (lambda _
+ (substitute* "Makefile.PL"
+ ;; The configuration provides no way to pass
+ ;; additional directories to search for the ncurses
+ ;; library, so just skip the search.
+ (("&search_lib\\('-lncurses'\\)") "'-lncurses'")))))))
+ (home-page "https://metacpan.org/release/Term-ReadLine-Gnu")
+ (synopsis "GNU Readline/History Library interface for Perl")
+ (description "This module implements an interface to the GNU Readline
+library. It gives you input line editing facilities, input history management
+facilities, completion facilities, etc. Term::ReadLine::Gnu is upwards
+compatible with Term::ReadLine.")
+ (license (package-license perl))))
+
(define-public perl-term-size-any
(package
(name "perl-term-size-any")