summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-31 14:10:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-31 14:10:25 +0200
commit23de2e1d5f8f7548e6f73085de23d9964774edbf (patch)
treefab69d4bb55f275f14012a724b7cb14bd307b57f /gnu/packages/perl.scm
parentec6ba5c1fe9308cbc18f06c99adcfe0d13396a18 (diff)
parent1c27f72fc2770d68243dd95b7c05adc3b2b02ea4 (diff)
downloadpatches-23de2e1d5f8f7548e6f73085de23d9964774edbf.tar
patches-23de2e1d5f8f7548e6f73085de23d9964774edbf.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm35
1 files changed, 29 insertions, 6 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d3e461c077..4dbe77c4e9 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5948,6 +5948,29 @@ cycle. Functions called in the package itself will still be bound by their
name, but they won't show up as methods on your class or instances.")
(license (package-license perl))))
+(define-public perl-net-dns-native
+ (package
+ (name "perl-net-dns-native")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/O/OL/OLEG/Net-DNS-Native-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "12bsv5jkic3q4arpzk6dda35didkn445v658j87rmi540dpnac85"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Net-DNS-Native/")
+ (synopsis "Non-blocking system DNS resolver")
+ (description
+ "This class provides several methods for host name resolution. It is
+designed to be used with event loops. Names are resolved by your system's
+native @code{getaddrinfo(3)} implementation, called in a separate thread to
+avoid blocking the entire application. Threading overhead is limited by using
+system threads instead of Perl threads.")
+ (license perl-license)))
+
(define-public perl-net-idn-encode
(package
(name "perl-net-idn-encode")
@@ -6422,19 +6445,19 @@ for a given module is comprehensive.")
(define-public perl-pod-simple
(package
(name "perl-pod-simple")
- (version "3.31")
+ (version "3.35")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/M/MA/MARCGREEN/"
+ (uri (string-append "mirror://cpan/authors/id/K/KH/KHW/"
"Pod-Simple-" version ".tar.gz"))
(sha256
(base32
- "04705pcs31s71vpmnpfdy8ds0q700q4cs2dlyssyrdjbvx3ymq3l"))))
+ "0gg11ibbc02l2aw0bsv4jx0jax8z0apgfy3p5csqnvhlsb6218cr"))))
(build-system perl-build-system)
- (home-page "http://search.cpan.org/dist/Pod-Simple//")
+ (home-page "http://search.cpan.org/dist/Pod-Simple/")
(synopsis "Parsing library for text in Pod format")
- (description "Pod::Simple is a Perl library for parsing text in
-the Pod (plain old documentation) markup language that is typically
+ (description "@code{Pod::Simple} is a Perl library for parsing text in
+the @dfn{Pod} (plain old documentation) markup language that is typically
used for writing documentation for Perl and for Perl modules.")
(license (package-license perl))))