summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-16 05:12:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-16 05:41:01 +0200
commitae3f3090333bb42c967055a909f107d102920eb3 (patch)
tree84fadcf1bef7ba0ae4daac515d4467de188ca88a /gnu/packages/perl.scm
parent803b9736689e2e3a772848f8a41c24488fb692b4 (diff)
downloadpatches-ae3f3090333bb42c967055a909f107d102920eb3.tar
patches-ae3f3090333bb42c967055a909f107d102920eb3.tar.gz
gnu: perl-datetime-format-flexible: Update to 0.32.
* gnu/packages/perl.scm (perl-datetime-format-flexible): Update to 0.32. [native-inputs]: Add perl-test-exception and perl-test-nowarnings.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3f20c8d058..83b8960845 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2390,16 +2390,18 @@ to do this without writing reams of structural code.")
(define-public perl-datetime-format-flexible
(package
(name "perl-datetime-format-flexible")
- (version "0.28")
+ (version "0.32")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/T/TH/THINC/"
"DateTime-Format-Flexible-" version ".tar.gz"))
(sha256
- (base32
- "1g63zs0q2x40h29r7in50c55g6kxiw3m2faw2p6c4rg74sj2k2b5"))))
+ (base32 "1vnq3a8bwhidcv3z9cvcmfiq2qa84hikr993ffr19fw7nbzbk9sh"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)
+ ("perl-test-nowarnings" ,perl-test-nowarnings)))
(propagated-inputs
`(("perl-datetime" ,perl-datetime)
("perl-datetime-format-builder" ,perl-datetime-format-builder)