summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:09:43 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:45:59 +0100
commit7b233133cea11b021dbeb4c9ef2faa1fba326071 (patch)
tree23c294efe79cf4a290cfb90c5ae0e5d126fb2ee8 /gnu/packages/perl.scm
parent55916fa2268b83c4d03cac8984594aa9979647e0 (diff)
downloadpatches-7b233133cea11b021dbeb4c9ef2faa1fba326071.tar
patches-7b233133cea11b021dbeb4c9ef2faa1fba326071.tar.gz
gnu: Add perl-string-shellquote.
* gnu/packages/perl.scm (perl-string-shellquote): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 38cc5e77b0..86d07c3ccc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7716,6 +7716,28 @@ fixed string interpolation, and simple width-matching.")
known prefixes.")
(license (package-license perl))))
+(define-public perl-string-shellquote
+ (package
+ (name "perl-string-shellquote")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RO/ROSCH/String-ShellQuote-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dfxhr6hxc2majkkrm0qbx3qcbykzpphbj2ms93dc86f7183c1p6"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/String-ShellQuote")
+ (synopsis "Quote strings for passing through a shell")
+ (description
+ "@code{shell-quote} lets you pass arbitrary strings through the shell so
+that they won't be changed.")
+ (license (package-license perl))))
+
(define-public perl-string-print
(package
(name "perl-string-print")