summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2017-03-23 13:16:59 +0100
committerAlex Sassmannshausen <alex@pompo.co>2017-03-26 11:33:35 +0200
commit21b7cf4287f5afec1ad5d969aec465f3f7261bd0 (patch)
treed333c9c02d51ae88c5c8a38bc0bf3659a28469e1 /gnu/packages/perl.scm
parent6ff5e9baeab6e1e6a8d49376f6d333e00885fec4 (diff)
downloadpatches-21b7cf4287f5afec1ad5d969aec465f3f7261bd0.tar
patches-21b7cf4287f5afec1ad5d969aec465f3f7261bd0.tar.gz
gnu: Add perl-file-pushd.
* gnu/packages/perl.scm (perl-file-pushd): New variable
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 086e1fae03..4944ceb2a2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3002,6 +3002,34 @@ of arbitrary depth and to delete an entire directory subtree from the
file system.")
(license (package-license perl))))
+(define-public perl-file-pushd
+ (package
+ (name "perl-file-pushd")
+ (version "1.014")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DAGOLDEN/File-pushd-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "02rlqvyy7gly3dsqwaa81aisyy9c791b8xvwzczcbgmcwgzkgaxm"))))
+ (build-system perl-build-system)
+ (home-page
+ "http://search.cpan.org/dist/File-pushd")
+ (synopsis
+ "Change directory temporarily for a limited scope")
+ (description "@code{File::pushd} does a temporary @code{chdir} that is
+easily and automatically reverted, similar to @code{pushd} in some Unix
+command shells. It works by creating an object that caches the original
+working directory. When the object is destroyed, the destructor calls
+@code{chdir} to revert to the original working directory. By storing the
+object in a lexical variable with a limited scope, this happens automatically
+at the end of the scope.")
+ (license asl2.0)))
+
(define-public perl-file-list
(package
(name "perl-file-list")