summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-20 17:17:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-21 03:20:11 +0100
commitfa79a908bb06f0c54b34334da57909b048f14995 (patch)
treec6c154ffd8efbaaeff473b2fc25b936082f26009 /gnu/packages/perl-check.scm
parentdacd8cf2e8ac4adc25f6e2306a30849295dbb291 (diff)
downloadpatches-fa79a908bb06f0c54b34334da57909b048f14995.tar
patches-fa79a908bb06f0c54b34334da57909b048f14995.tar.gz
gnu: Add perl-test-requiresinternet.
* gnu/packages/perl-check.scm (perl-test-requiresinternet): New public variable.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index b1d1f08150..5df2940bd6 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -869,6 +869,30 @@ checks for pod coverage of all appropriate files.")
If this fails, then rather than failing tests this skips all tests.")
(license perl-license)))
+(define-public perl-test-requiresinternet
+ (package
+ (name "perl-test-requiresinternet")
+ (version "0.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MALLEN/Test-RequiresInternet-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0gl33vpj9bb78pzyijp884b66sbw6jkh1ci0xki8rmf03hmb79xv"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Test-RequiresInternet/")
+ (synopsis "Easily test network connectivity when running tests")
+ (description
+ "This Perl module is intended to easily test network connectivity to
+non-local Internet resources before functional tests begin. If the sockets
+cannot connect to the specified hosts and ports, the exception is caught and
+reported, and the tests skipped.")
+ (license perl-license)))
+
(define-public perl-test-script
(package
(name "perl-test-script")