summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 01:04:08 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:28 +0300
commitab1253159f66c18726914461bafe3ca248111cc7 (patch)
tree61ec75aafc8080d08103a377c515870566eeee2a /gnu/packages/perl-check.scm
parent60628f54524ab0fbce77ddea103ae608c05cbd36 (diff)
downloadpatches-ab1253159f66c18726914461bafe3ca248111cc7.tar
patches-ab1253159f66c18726914461bafe3ca248111cc7.tar.gz
gnu: Add perl-test-filename.
* gnu/packages/perl-check.scm (perl-test-filename): New public variable.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index c04344a70b..3129048488 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -456,6 +457,28 @@ testing exception-throwing code with about the same amount of typing.")
for testing.")
(license perl-license)))
+(define-public perl-test-filename
+ (package
+ (name "perl-test-filename")
+ (version "0.03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DAGOLDEN/Test-Filename-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gpw4mjw68gnby8s4cifvbz6g2923xsc189jkw9d27i8qv20qiba"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-path-tiny" ,perl-path-tiny)))
+ (home-page "http://search.cpan.org/dist/Test-Filename/")
+ (synopsis "Portable filename comparison")
+ (description "Test::Filename provides functions to convert all path
+separators automatically.")
+ (license asl2.0)))
+
(define-public perl-test-files
(package
(name "perl-test-files")